Kritische Kubernetes-Schwachstelle im Ingress NGINX Controller ermöglicht Clusterübernahme

Am 24. März 2025 wurden mehrere Schwachstellen im weit verbreiteten Ingress NGINX Controller für Kubernetes veröffentlicht – darunter die kritische Lücke CVE-2025-1974, die mit einem CVSS-Score von 9.8 bewertet wird. Insgesamt sind fünf Schwachstellen betroffen, von denen vier die Remote Code Execution (RCE) ermöglichen. Sie betreffen vor allem Installationen, bei denen der Validating Admission Controller öffentlich erreichbar ist oder auf anderem Weg kompromittiert werden kann.

Laut dem Sicherheitsunternehmen Wiz können Angreifer durch diese Lücken vollständigen Zugriff auf das Cluster erlangen – ein Szenario, das als „IngressNightmare“ bezeichnet wird. Mehr als 1.000 Systeme allein in Deutschland gelten als besonders gefährdet. Zwar ist derzeit keine aktive Ausnutzung bekannt, das Bundesamt für Sicherheit in der Informationstechnik (BSI) rechnet jedoch mit baldigen Angriffen.

Betroffen sind:

  • Alle Versionen vor 1.11.0
  • v1.11.0 bis einschließlich v1.11.4
  • v1.12.0

Prüfen Sie, ob der verwundbare Controller eingesetzt wird:

kubectl get pods --all-namespaces --selector app.kubernetes.io/name=ingress-nginx

Updaten Sie schnellstmöglich auf eine sichere Version (1.11.5 oder 1.12.1). Unterbinden Sie den Zugriff auf den Admission Controller (TCP 8443) aus dem Internet. Falls ein sofortiges Update nicht möglich ist: beschränken Sie den Zugriff weitestgehend oder deaktivieren Sie den Controller temporär

Related Posts

Spring Security – Autorisierungs-Bypass durch fehlerhafte Annotationserkennung (CVE-2025-22223)

Am 19. März 2025 wurde eine mittelschwere Sicherheitslücke (CVE-2025-22223, CVSS 5.3) in Spring Security veröffentlicht. Die Lücke betrifft Anwendungen, die @EnableMethodSecurity nutzen und Methoden mit Sicherheitsannotationen auf parametrisierten Typen oder geerbten Methoden versehen haben – ohne direkte Annotation auf der Zielmethode. In diesem Fall kann es zu einem Autorisierungs-Bypass kommen. Betroffen ist Spring Security 6.4.0 – 6.4.3. Ein Update auf 6.4.4 wird empfohlen.

Read More

Kritischer Auth-Bypass in Fortinet-Produkten aktiv ausgenutzt (CVE-2024-55591, CVE-2025-24472)

Fortinet warnt vor einer kritischen Sicherheitslücke in FortiOS und FortiProxy, die derzeit aktiv ausgenutzt wird. Die Schwachstellen (CVE-2024-55591 und CVE-2025-24472) ermöglichen es Angreifern, über präparierte Anfragen an das Node.js WebSocket-Modul oder manipulierte CSF-Proxy-Requests die Authentifizierung zu umgehen und Super-Admin-Rechte zu erlangen.

Read More

CVE-2025-29927 Umgehung der Authorisierung in Next.js möglich

Am 21. März 2025 wurde eine kritische Sicherheitslücke (CVE-2025-29927, CVSS 9.1) in Next.js bekannt, die es Angreifern erlaubt, Autorisierungsprüfungen zu umgehen, sofern diese innerhalb von Middleware implementiert sind. Die Schwachstelle betrifft eine Vielzahl von Versionen: konkret alle Releases von Next.js größer als 11.1.4 bis einschließlich 13.5.6, sowie die Versionen >14.0 bis <14.2.25 und >15.0 bis <15.2.3.

Read More